descarregar PDF

4.1. Aprendre llegint

Una fórmula és una expressió matemàtica o de text que es refereix a altres cel·les o valors constants, i que s'empra per calcular el valor d'una cel·la tot utilitzant el contingut d'altres.

Per tal que el full de càlcul interpreti el contingut d'una cel·la com a fórmula, és necessari que comenci pel símbol =, + o -. Escriurem la fórmula a la barra de fórmules, i la cel·la seleccionada representarà el resultat de l'aplicació de la fórmula.

 

 

Un operador és el símbol que representa l'operació que es farà amb els elements de la fórmula. Alguns d'ells són: aritmètics (+ (suma), - (resta), * (multiplicació), / (divisió) i % (percentatge)), o de concatenació de text (&, concatena dos textos en un de sol).

Tipus de fórmules

Hi ha diferents tipus de fórmules:

  • Amb valors constants, com ara els nombres; per exemple = 54*5/3
  • Amb referències a altres cel·les o conjunts de cel·les; per exemple, =C*3 + 50 o =SUMA(B1:B3) indica que es realitzarà la suma dels valors de les cel·les B1+ B2 + B3.
  • Amb prioritats modificades, és a dir, que les operacions que es realitzaran primer són les incloses dintre del parèntesi; per exemple, =(B4+B9)*5/4

Funcions

Una funció és una fórmula predefinida pel full de càlcul per tal de facilitar el càlcul d'operacions habituals. Hi ha diferents categories: matemàtiques i trigonomètriques, estadístiques, lògiques, de text, data i hora, enginyeria, financeres, bases de dades, informació, externes, definides per l'usuari.

Per activar l'assistent de fórmules, seleccionarem l'opció 'Funció' del menú 'Insereix', o premerem el botó de la barra de fórmules 'Fx'.

 

 

Si seleccionem la funció que desitgem i l'acceptem, aquesta s'insereix a la barra de fórmules i s'obre un quadre de diàleg que és l'assistent per introduir els valors de la fórmula.

Entre les funcions matemàtiques més utilitzades trobem la suma. Una de les eines de què disposem és la suma automàtica, que permet sumar el contingut de fileres o columnes de forma automàtica. És l'equivalent a ' =SUMA()'. Per fer-la servir, seleccionarem la cel·la que volem que contingui el resultat i premerem el botó de la barra d'eines. Seleccionarem les cel·les que volem sumar i premerem la tecla Enter.

Si volem sumar dades que no són contigües, escriurem a la barra de fórmula els arguments necessaris; per exemple, si escrivim SUMA (A1:A3;B1), vol dir que sumem les dades contingudes a les cel·les A1, A2, A3 i B1.

 

 

Una altra funció matemàtica és el producte. Per calcular el producte d'un conjunt de nombres o cel·les, farem servir '=PRODUCTE()'.

Entre les funcions estadístiques més comunes trobem la mitjana aritmètica d'un conjunt de nombres o cel·les. Treballant amb CALC, utilitzarem la funció '=MITJANA()'. Amb Excel, utilitzarem 'PROMEDIO()'.

Si escrivim '=MITJANA(A1:A3;B5;8)' a la barra de fórmules, a la cel·la seleccionada apareixerà la mitjana d'A1, A2, A3, B5 i el nombre 8.